M14 Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3,252 Posts
Discussion Starter · #1 ·
I was going over my Socom16 the other day and noticed something odd... the oprod hits the front corner of the receiver when it's fully retracted. There is a little shiny 'notch' cut right were the oprod cantilevers down to the spring housing, just in front of the radius.

My first thought was to relieve it with a Dremel but wonder if this is normal or something I need to let SAI handle? Any one else see this on theirs?

Sorry, no photo yet, I'm out of town...
 

·
Registered
Joined
·
10,496 Posts
Mine has it too and I just cleaned it up a little with a Dremel and then used a little cold blue to darken it.
 

·
Registered
Joined
·
35 Posts
mine too

all of my SAI op rods do the same, but the GI's do not.
 

·
Registered
Joined
·
255 Posts
People love or hate the buffers, but a buffer came with literally every other firearm I own. I know it wasn't designed with the M14, but I figure it can't hurt. I love the buffer in my M14. I sleep well at night knowing its in there. heh.. This may put your issue to rest as well.
 

·
Registered
Joined
·
1,112 Posts
All of my SAI M1A's have USGI op rods and all have simular marks on them. A minor radius cut with a file or a stone on the receiver, and stone the burr back on th op. rod and some touch up blue and you will be good to go. It is a SAI receiver problem, my Chinese M14's have no such issues either with Chicom or USGI op rods.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top