M14 Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I;ve just put my M14 into a MARSTAR stock wich has a full lengh rail that covers the top of the reciever but unless i take of the rail that covers the top of the reciever the damb thing won't eject,the empty cases keep hiting the rail then jam! i thought it might be a designe fult but see the same top rail in many other stock mods for the M14 and can't find any information to say they have ejection problems,..
Can anybody help me on this matter..do i have a problem with my ejector or are these top rails a load a crp!!...
 

·
Registered
Joined
·
1,684 Posts
sounds like and issue with either your ejector or ejector spring. It happens to us in the states with low scope mounts or rails with commercial non usgi parts... So you might want to replace the spring first...
 

·
Registered
Joined
·
467 Posts
I thought everyone down under had to turn their guns in a few years back??

Try removing one coil at a time from your ejector spring until it works or until you need a new ejector spring.
 

·
Registered
Joined
·
245 Posts
Chinese rifle? If so, replace bolt springs with Gi, or trim 2 coils from extractor spring and 3 from the ejector...
should fix it.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
Gangus

Thanks heaps! that gives me something to work with,i have to admit it has been prity sloppy with it's ejections even without the top rail,the spent cases just seem to tumble out instead of throwing...
 
1 - 6 of 6 Posts
Top