M14 Forum banner

hammer not locking back

931 Views 10 Replies 5 Participants Last post by  ltdave
ive decided to use an older TG for my Entreprise Arms (SPIT) M14...

i put it in and was cycling the action and function checking. as i ran the oprod back after squeezing the trigger the trigger wouldnt reset forward because the hammer wasnt locking. pulled it back out and the hammer locks just fine...

reassembled the rifle and still no dice. i would have a nice full auto rifle but obviously dont want that trouble...

im wondering whats wrong because i can see no adverse wear on the hammer or sear. im not a trigger smith so im not anywhere close to being an expert but still...

what say ye?
1 - 11 of 11 Posts
Sometomes the stock can keep the hammer from locking into the sear. Take a look at that.
yeah im going to use a GI synthetic for this. any idea where to look?

Not really sure, as I've never had that problem. I've seen others talking about it though. Maybe someone else will chime in soon.
Aloha Lt.Dave:

For the sake of testing... if you could try any other stock and then another trigger group, it might answer most of the questions here...

I would first try anyone else's trigger group. If it works then its probably your trigger group (specifically what can be determined later). If this xtra trigger group fails to set the hammer, then it may be the stock.

If no xtra trigger group available, then try another stock... any M14 stock and see if this problem still occurs. If another stock does the trick then maybe the trigger group angle might be off and some repair may be necessary on your original stock.

Did this problem just occur? Is there anything different or new in your current setup that might have caused this situation?

I am sure you will be able to resolve this... and xtra parts sure can come in handy... Good Luck!


Tom O.
See less See more
I had this very same problem, with one of my Entreprise M14's. No it's not an Entreprise problem. I replaced the hammer and trigger and all has been fine with the world.


yes i know its not an Entreprise Arms (SPIT) problem but it just cropped up.

to be fair i swapped a beautiful GI wood stock and the trigger group at the same time.

i will go back and swap only ONE part at a time...


Ahhh--the old stock swap.

What's probably happening is that there's too much wood under the rear of the trigger group, causing the back of the group to hang too low. When the hammer gets sent back, it isn't reaching the sear.

Tinker around with different combos, but you may need to remove some wood from under the rear of the trigger group.

i just checked the fiberglass stock with my other TG. it is doing the same thing...

the 2nd TG DOES lockback in my walnut stock...

ive notice that:

if i work the oprod without holding the trigger, both will lockback.
if i trip the hammer and work the oprod while holding the trigger back both will FAIL to lock...

something is causing the disconnector to not function properly...

does this narrow things down? should i still file a bit on my stock?


See less See more
It sounds like it's the fiberglass stock and that you'll need to remove material under the rear of the trigger group.
well i decided to try shooting this rifle (just in case i had a FAST rifle)...

the hammer would follow the bolt but not 'fall' with enough force to fire...

(darn! :D ) it would lock back about 90% of the time though so i guess i dont need to take out too much stock material...

1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.