M14 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter · #1 ·
Hey y'all, I know a guy who has a Armscorp M14 and the extractor keeps flying out of this rifle after only a few shots, what would cause this? He says its a USGI extractor and has even replaced the spring and plunger piece, any ideas?

James
 

·
Registered
Joined
·
4,057 Posts
This was a common Problem with SAI Extractors, the part that goes thru the Bolt is slightly too long and protrudes just enough out of the Bottom to dismount it during firing,I however have not heard of a GI Extractor doing that, they are normally the Cure for it!
Replace the Extractor, I don't think You are dealing with a GI Extractor!GI3
 

·
Registered
Joined
·
109 Posts
Discussion Starter · #3 ·
This was a common Problem with SAI Extractors, the part that goes thru the Bolt is slightly too long and protrudes just enough out of the Bottom to dismount it during firing,I however have not heard of a GI Extractor doing that, they are normally the Cure for it!
Replace the Extractor, I don't think You are dealing with a GI Extractor!GI3
That's exactly what I told him, but he said the guy who built it told him a USGI, I think its SAI, now a Garand extractor will work right, they changed the drawing cause of problems encountered with Blank firing right? Now if the Tang i guess its called is too long, can it be shaved to fit?
 

·
Registered
Joined
·
109 Posts
Discussion Starter · #5 ·
Yes it can. Get after it for him and get that rifle back up and firing.DI5
Hey Rip you got it yet? If you don't have it by tomorrow I'm calling Fedex for a WTF over!! I've got an extra one around here somewhere and I'll see if that works, thanks guys

James
 
1 - 6 of 6 Posts
Top