M14 Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
182 Posts
Discussion Starter #1
Hi,

Took pics of some extractors and even though I've read a lot on how to
to tell USGI from SA cast extractors,would really appreciate if someone could take a look at pics and maybe tell me what they are.

You can PM me your contact info and can text or email them to you.

Thanks a lot
Doug
 

·
Registered
Joined
·
4,006 Posts
Hi,

Took pics of some extractors and even though I've read a lot on how to
to tell USGI from SA cast extractors,would really appreciate if someone could take a look at pics and maybe tell me what they are.

You can PM me your contact info and can text or email them to you.

Thanks a lot
Doug
Doug, you should post those pics right here on this thread. Not only do you get some info, but that info is passed around to other members. That's what a Forum is all about. dozier
 

·
Registered
Joined
·
182 Posts
Discussion Starter #3
Dozier,
Very good advice.Can you post them on my behalf if I send them too you?
 

·
Registered
Joined
·
4,006 Posts
Don't know. Computer has been acting upr ecently, and can't even open up any attachments. Maybe someone else can chime in. Itw ould also help to know where you aquired the extractors and if there are any marks on them. Sorry, dozier
 

·
Registered
Joined
·
182 Posts
Discussion Starter #6
Got them from another M1A shooter earlier today
along with other small spare parts.

No markings except for handling mark.
Two are a kind of matte black and two are
a blued/black finish with what looks like machine
marks.

One of the blued ones is in the SM rifle i got about a month ago.
 

·
Registered
Joined
·
182 Posts
Discussion Starter #8
No mold markings on 3 of them.Would need to remove on installed in bolt,but will
pass on that for now.
 

·
Registered
Joined
·
661 Posts
The cast piece that came in my loaded didnt have a cast number on it but u could tell a diffrence in quality. The usgi just looked and the metal seemed to feed better
 
1 - 9 of 9 Posts
Top